WordPress4.6で画面にエラー PHP7.1には非対応!?

WordPress4.6で画面にエラー PHP7.1には非対応!?

この記事を読むのに必要な時間は約 1 分57秒です。

w001

スポンサーリンク

WordPress4.6で画面にエラー PHP7.1には非対応!?

新しいローカル環境にWordPressをインストールしようとしたらインストール実行画面でなぜかエラーが表示されてしまいました。

Warning: Parameter 1 to wp_default_styles() expected to be a reference, value given in C:\Apache24\htdocs\wordpress\wp-includes\plugin.php on line 600

気にせずにそのままインストールを続行したらインストールできましたが、管理画面やブログ画面にもエラーが・・・!?

Warning: Parameter 1 to wp_default_scripts() expected to be a reference, value given in C:\Apache24\htdocs\wordpress\wp-includes\plugin.php on line 600

Warning: Parameter 1 to wp_default_styles() expected to be a reference, value given in C:\Apache24\htdocs\wordpress\wp-includes\plugin.php on line 600

調べてみるとWordPress4.6はPHP7.1に対応していないようで、その他にも不具合があるようです。PHP7.1はWordPress4.7からサポートされるようです。

一旦PHPのバージョンを7.0に落としたらエラーは解消されました。PHP7.1はWordPress4.7がリリースされてから改めてバージョンアップしてみようと思います。

スポンサーリンク
ブログランキング・にほんブログ村へ

シェアする

フォローする

関連記事